It’s time for a well needed security update. It fills some needed holes that could be exploited. I’ve installed it on my servers and didn’t run into any issues as expected because of the affected components don’t touch our programs. Read more about the update here. If you haven’t updated yet please do it now !