The people at PHP have solved the issue with 5.2.7 and released it as 5.2.8. I’ve installed and tested on my test server without a problem and will upgrade my production machines over the weekend.

This release addresses a regression introduced by 5.2.7 in regard to the magic_quotes functionality, that was broken by an incorrect fix to the filter extension. All users who have upgraded to 5.2.7 are encouraged to upgrade to this release, alternatively you can apply a work-around for the bug by changing “filter.default_flags=0″ in php.ini.

I hope this one stays a little longer active than the previous version.