MySQL released a new version of the 5.5.x branch which is already usuable in our setup when you read this blogpost. It works perfectly on my test machine. It includes several high-impact changes to address scalability and performance issues in MySQL Server. Please note that MySQL 5.5.10 does also have an incompatible change besides the enhancements and bugfixes. Read the release notes for more details.

Please note that because the library is incompatible you might need to recompile all your library depended apps like PHP, Postfix and Dovecot. Please also the change in the library reference that is still an issue. (it’s now 18 instead of 16)

sudo install_name_tool -id /usr/local/mysql/lib/libmysqlclient.18.dylib /usr/local/mysql/lib/libmysqlclient.dylib

Also I would like to mention an interview with Tomas Ulin, Vice President, MySQL Engineering, who answers questions about the GA release of MySQL 5.5.

Read this documentation on how to ugrade this version using the package installer of MySQL.