10.6.5 -> 10.6.7 breaks postfix setup (with fix)

started at 22 Mar 2011 by robcd
  • robcd
    22 Mar 2011

    Dear Postfix forum,

    After upgrading my Mac OS X client, I got the following error message:

    ... postfix/smtpd[526]: fatal: unsupported dictionary type: mysql

    I noticed that the /usr/libexec/postfix/smtpd executable had been changed, together with who knows what else in that directory. So I restored the old one, only to get a similar error message from the trivial-rewrite executable (in the same directory). So I restored that as well, followed by the cleanup one, and then all is well again.

    So a couple of questions:

    * What should I do to fix things properly?

    * How can I avoid having to do this next time I upgrade the OS?

    Thanks and best regards,

    Rob

    PS Setup has otherwise worked great - many thanks!

  • Richard
    23 Mar 2011

    Hi Rob,

    This is a known problem and if you look at the blog and look at the articles that talk about the security updates you see that this sometimes happens and how to fix it.

    Here is an example that will help you solve your problem:
    http://diymacserver.com/2010/11/12/mac-os-x-update-10-6-5-and-security-update-2010-007/

Reply

You must log in to post.