The PHP development team released 5.4.1, it contains some security updates and I urge you to update it if you were using 5.4.0 on a production platform. I’ve successfully tested it on my servers without a noticeable problem.

  • Fixed bug #54374 (Insufficient validating of upload name leading to corrupted $_FILES indices). (CVE-2012-1172).
  • Add open_basedir checks to readline_write_history and readline_read_history.

To see the complete buglist solved in this release, read them in the ChangeLog.

For instructions on how to upgrade PHP please read: Upgrading PHP.